Government Security
Network Security Resources

Jump to content

Photo

Open Sshd Help

shell ssh
  • Please log in to reply
7 replies to this topic

#1 frank_flyn

frank_flyn

    Private

  • Members
  • 19 posts

Posted 15 March 2006 - 07:37 AM

I am using Suse 10.0.

When attempting to start oppen sshd from root with the 'sshd' command from the shell console, I get the following error message.

"sshd re-exec requires execution with an absolute path."

Can someone please point out the correct syntax, or point out whats going on.

Thanks in advance.

#2 Guest_stay_*

Guest_stay_*
  • Guests

Posted 15 March 2006 - 08:11 AM

if i'm not wrong it's started by default at suse. then also the output would make sense: re-exec

#3 treebug

treebug

    Private First Class

  • Members
  • 31 posts

Posted 15 March 2006 - 08:24 AM

when it says absolute path, that means you have to use the full path name along with the binary to execute it. for example on the distros i am running it is
'/usr/sbin/sshd'
if this doesn't work try 'which sshd' to find the path

#4 kroylar

kroylar

    Private First Class

  • Members
  • 51 posts

Posted 15 March 2006 - 12:21 PM

Yes. It is already running. Try a 'ps ax' just to verify. If you want to start it again, you'd first need to stop the current proccess. There should be an init.d or rc.d script corresponding to sshd that you would use to stop it.

#5 frank_flyn

frank_flyn

    Private

  • Members
  • 19 posts

Posted 16 March 2006 - 04:52 PM

Thanks guys. I read that it was on as a service, so I tried to connect to it using putty from a windows xp box. The default ssh port on putty is 22, however it says that server refused connection.

Again I'd be greatful if you guys have any suggestions.

Thanks in advance.

#6 drygol

drygol

    Corporal

  • Members
  • 153 posts

Posted 17 March 2006 - 01:48 AM

Thanks guys. I read that it was on as a service, so I tried to connect to it using putty from a windows xp box. The default ssh port on putty is 22, however it says that server refused connection.

Again I'd be greatful if you guys have any suggestions.

Thanks in advance.


first search for process ---> ps axf|grep sshd <-- if there will be more thatn 2 lines listed then sshd is wrkin , if only one then u have to start investigating why it didnt launch.
Second - did u add sshd to your default runlevel to get it started during boottime ?
third - like guys said before , try to run it manualy smth like ---> /usr/sbin/sshd
this cmd should return errors to you if any.
fourth - check your default config file which is proly located in /etc/ssh directory.
If there is no conf then u wil know why its not wrkin ;)

#7 donk0yote

donk0yote

    Private

  • Members
  • 19 posts

Posted 17 March 2006 - 09:39 AM

you will also need to allow the port to be open in the firewall,
go into yast security and look at the firewall settings, might be why the connection is refused.

#8 frank_flyn

frank_flyn

    Private

  • Members
  • 19 posts

Posted 19 March 2006 - 04:27 AM

Many thanks. I will crack on witht hose recomendations.

you will also need to allow the port to be open in the firewall,
go into yast security and look at the firewall settings, might be why the connection is refused.







Also tagged with one or more of these keywords: shell, ssh