Government Security
Network Security Resources

Jump to content

Photo

John The Ripper 1.6.37

cache hash patch
  • Please log in to reply
4 replies to this topic

#1 TheOther

TheOther

    Private First Class

  • Members
  • 98 posts

Posted 03 May 2005 - 10:25 PM

Hi guys,

I've installed version 1.6.37 because I need this version to apply the mscache patch.
But the charsets files like all.chr and alpha.chr are missing in this version, I've copied these files from the 1.6 version but I still get the error:
./john -format:mscash -i:all.chr /home/xxxxx/sock.txt
Loaded 8 password hashes with 8 different salts (M$ Cache Hash [mscash])
No charset defined for mode: all.chr

Thx

#2 macman

macman

    Private First Class

  • Members
  • 27 posts

Posted 03 June 2005 - 02:52 AM

is the all.chr in the same directory which you are executing? maybe adding the full path would correct this. also check the permissions are set correctly

#3 setti

setti

    Private

  • Members
  • 2 posts

Posted 28 February 2006 - 09:20 AM

Ive got exactly the same problem.
Did you already solve it?

And yes, the *.chr files are in the right dir....

€dit: ok i manged to get now "Incorrect charset file format: all.chr"

While i tried to create my new *.chr files i only get "Loaded 0 plaintexts, exiting..." without any result.

#4 donk0yote

donk0yote

    Private

  • Members
  • 19 posts

Posted 08 March 2006 - 10:00 AM

hmmm i never have to type -i:all.chr just -i:all
maybe you got something wrong in the "all" definition portion of
the john.conf? i remember there was a README in that version that said you had to copy the docs and .chr files over from 1.6.36, seems like the john.conf might have to be copied too?

#5 drygol

drygol

    Corporal

  • Members
  • 153 posts

Posted 14 March 2006 - 12:44 AM

fyi 1.7.0.1 is out ---> http://www.openwall.com/john/





Also tagged with one or more of these keywords: cache, hash, patch